Installing VCL components into Delphi and C++Builder

To install CBFS Filter to component palette you can use the package, installed with CBFS Filter. The packages are located in <CBFS Filter>\VCL\Units\DelphiX or <CBFS Filter>\VCL\Units\BuilderX folder (X stands for IDE version number) depending on dev.tool version.

Alternatively, if you want to install the component from the source code, you need to do the following:

  • Start Delphi or C++Builder IDE.
  • Select Main Menu->Component->Install component
  • In the dialog that appears select if you want to install the component to existing package or create new package.
  • Specify Unit name (CBFSFlt.dcu) and select the package
  • Click OK
  • Take the above steps for CBFSFltApi.dcu as well.
The package will be re-compiled and the component will be installed to component palette. The component will appear on "CBFS Filter" tab in component palette.

To avoid problems with compilation of projects, which use CBFS Filter, you need to setup paths as described. By default the paths are set during installation. However if the settings were changed or installation didn't work as expected, you can use the below procedure to setup paths.

  • Delphi:
    Before using CBFS Filter in your projects, you need to tune-up global paths in Delphi IDE. Paths are set in Main menu->Tools->Environment options. Environment Options dialog appears. Find Library or Directories tab in the page control and you will find directories configuration page.
    • Set the "output directory", "unit output directory" and "BPL output directory" (if present) settings for the package to the folder, where the compiled packages will be stored after compilation.
    • add the name of the folder with CBFSFlt.dcu (<CBFS Filter>\VCL\Units\DelphiX) to the "source path" setting.

    To use CBFS Filter in your projects, you need to add "CBFSFlt" to Uses clause of one or more of your units. Then you can create instances of TCBFSFilter class and use them. You don't need to ship any external DLLs with your compiled project.

  • C++Builder:
    Before using CBFS Filter in your projects, you need to tune-up global paths in your development tool. Paths are set in Main menu->Tools->Environment options. Environment Options dialog appears. Find Library or Directories tab in the page control and you will find directories configuration page.
    • Set the "output directory", "unit output directory" and "BPL output directory" (if present) settings for the package to the folder, where the compiled packages will be stored after compilation.
    • add the name of the folder with CBFSFlt.obj and CBFSFlt.dcu (<CBFS Filter>\VCL\Units\BuilderX) to the "include path" and "library path" settings.

    To use CBFS Filter in your projects, you need to include "CBFSFlt.hpp" (header file) to one or more of your files. Also, you need to add CBFSFltBX.lib (X stands for IDE version number) to the project. You don't need to ship any external DLLs with your compiled project.